The Issue Tracker

This thread has been locked.

p0sixkillah

Explosive Barrels
         
Joined
May 10, 2019
Messages
84
The purpose of this thread is to gather information about bugs and general issues with SFM and SFMR. We'll have issues reported as such:

Reported by: <@user>
Version #: <SFM type & build ID> (ex: 'Normal - 0.9.8.15', 'Reborn - 0.9.8.15')

Issue Description:
<description>

Known Workarounds:
<known workarounds / 'None'>


If you wish to see an issue reported here, please create a thread in the Source Filmmaker forum, or contact the forum moderators via PMs, and try to keep the format similar to the above so we can format it accordingly! :okavi:
 

p0sixkillah

Explosive Barrels
         
Joined
May 10, 2019
Messages
84
Reported by: Fames#9725
Version #: Normal - 0.9.8.15

Issue Description:
Playhead following mouse in the motion editor, not being able to click on the viewport.

Known Workarounds:
CTRL + M -> Escape -> CTRL + A
or
Hold shift and drag-select a small area
 

p0sixkillah

Explosive Barrels
         
Joined
May 10, 2019
Messages
84
Reported by: Fames#9725
Version #: Normal - 0.9.8.15

Issue Description:
Broken reflections/none at all/bloom of death

Known Workarounds:
Open the console via Windows -> Console. Set mat_fastspecular and/or mat_specular to 0 -> type in buildcubemaps -> restart SFM after it's done
 

p0sixkillah

Explosive Barrels
         
Joined
May 10, 2019
Messages
84
Reported by: Practical Problems
Version #: Normal - 0.9.8.15

Issue Description:
Mouse movement in the in-game mode causes erratic movement to occur

Known Workarounds:
If on Windows 7, make sure to set the windows scaling to default
 

p0sixkillah

Explosive Barrels
         
Joined
May 10, 2019
Messages
84
Reported by: Pajser#1274
Version #: Normal - 0.9.8.15

Issue Description:
Cameras and/or models stop responding to commands after the 60 seconds mark.

Known Workarounds:
Double-click the timeline in the clip editor and extend the yellow clips.
 

p0sixkillah

Explosive Barrels
         
Joined
May 10, 2019
Messages
84
Reported by: LemonTea#0594
Version #: Normal - 0.9.8.15 (BuildID 489744)

Issue Description:
In the Particle Editor Tool, "System Properties>Add new..." causes SFM to close. No freezing, just the window closing animation.
Following the crash, an average of 34 files need to be retrieved via validation.

Known Workarounds:
N/A
 

p0sixkillah

Explosive Barrels
         
Joined
May 10, 2019
Messages
84
Reported by: 9joao6#9006
Version #: Normal - 0.9.8.15 (BuildID 489744)

Issue Description:
Missing model preview in the model browser.

Known Workarounds:
Delete ingamedialogconfig.vdf in platform\scripts.
 

p0sixkillah

Explosive Barrels
         
Joined
May 10, 2019
Messages
84
Reported by: Papyesh#7067
Version #: Normal - 0.9.8.15 (BuildID 489744)

Issue Description:
Blinking viewport, turning black when moving around, etc.

Known Workarounds:
Type -usevgui in launch options
or
Go to "Windows" > "Engine Window" > "Auto Hide Engine Window"
 

p0sixkillah

Explosive Barrels
         
Joined
May 10, 2019
Messages
84
Reported by: FallenNoob#4457
Version #: Normal - 0.9.8.15 (BuildID 489744)

Issue Description:
Loading certain models causes an "Engine Hunk Overflow" error to display, followed by SFM crashing.

Known Workarounds:
Add the following line to /usermod/cfg/autoconfig.cfg:
r_hunkalloclightmaps 0
 
Top Bottom